Delays with demographic scoring of new records
Incident Report for MadKudu
Postmortem

What happened?
On Friday, the 13th of January 2022, around 6 PM UTC, one of our data enrichment providers started experiencing issues. We observed higher than usual volumes of rate-limited records on our provider’s end, which slowdowns MadKudu’s real-time scoring.

Impact
Real-time scoring of new records could have been delayed for up to 2 hours.
Batch scoring was not impacted.

Resolution
Our engineering team monitored the recovery of our data enrichment provider. The issue was resolved in under 2 hours. The backlogs of records to score were processed and real-time scoring was back to normal functioning.

Posted Jan 20, 2023 - 03:11 PST

Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 11:53 PST
Investigating
Our infrastructure is experiencing delays in realtime demographic scoring of new records. Our team has been notified and is looking into the issue
Posted Jan 13, 2023 - 10:32 PST
This incident affected: Realtime scoring.