app.madkudu.com may be inaccessible
Incident Report for MadKudu
Resolved
This incident has been resolved.
Posted Sep 02, 2023 - 00:32 PDT
Investigating
Our app is experiencing errors and may be inacessible. We are investigating the issue.
Posted Sep 02, 2023 - 00:28 PDT
This incident affected: app.madkudu.com.