Sales Copilot Unavailable

Incident Report for MadKudu

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 17:33 PDT

Update

We are continuing to work on a fix for this issue.
Posted Apr 20, 2026 - 17:33 PDT

Identified

We’ve identified an issue affecting Sales Copilot and are actively working on a fix. We expect full recovery within approximately 90 minutes.
Posted Apr 20, 2026 - 15:56 PDT
This incident affected: msi.madkudu.com.