Sales Copilot service disruption

Incident Report for MadKudu

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:52 PDT

Monitoring

Service functionality has been restored. We are continuing to monitor it to ensure full stability.
Posted Oct 21, 2025 - 00:51 PDT

Update

We're still monitoring our dependent services.
Posted Oct 20, 2025 - 18:52 PDT

Identified

Sales Copilot is currently experiencing renewed service disruption as some of our dependent services are facing issues again
Posted Oct 20, 2025 - 18:39 PDT

Monitoring

Service functionality has been restored. We are continuing to monitor it to ensure full stability.
Posted Oct 20, 2025 - 17:13 PDT

Identified

Sales Copilot is currently experiencing service degradation due to widespread outages affecting multiple online services, including our infrastructure providers.

Our team is actively monitoring the situation and implementing mitigations as providers restore functionality. We will provide updates as more information becomes available.
Posted Oct 20, 2025 - 12:58 PDT
This incident affected: msi.madkudu.com.