app.madkudu.com may be inaccessible
Incident Report for MadKudu
Resolved
This incident has been resolved.
Posted May 02, 2022 - 01:10 PDT
Investigating
Our app is experiencing errors and may be inacessible. We are investigating the issue.
Posted May 02, 2022 - 01:06 PDT
This incident affected: app.madkudu.com.